
American Innovations (AI) is pleased to announce version 1.9 of our Pipeline Compliance System Axis® 
software (PCS Axis®). This document explains how to upgrade the PCS Axis database, application, and job 
service agent to version 1.9. The information applies to the following types of upgrade installations:

 Client/server installation (with and without replication)

 Subscription in a client/server network with replication (remote client)

 Single-user local installation in a non-client/server network

Topics in this document include those in the following list:

 PCS Axis Best Practices (page 2)

 Upgrading a Client/Server Installation of PCS Axis (page 9)

 Creating a Database Maintenance Job on the Server (page 17)

 Upgrading a PCS Axis Subscription for a Remote Client (page 18)

 Upgrading a Single-User Local Installation in a Non-Client/Server Network (page 22)

 Product Support and Training (page 28)

Information in this document is intended for the IT System Administrator or a person with a Windows 
Administrator user account. The person performing the upgrade must also be assigned the database role 
of DBO (database owner) to successfully upgrade the database when using PCS Axis Connection 
Manager. Database roles are assigned to SQL logins either by your company’s IT System Administrator or 
Database Administrator. 

IMPORTANT: The size of the database can influence the amount of time it takes to upgrade to v1.9. 

If you have questions or need assistance with the upgrade installation, contact PCS Technical Services using 
the contact information on page 28. 

PCS Axis® v1.9 Upgrade Installation May 2015
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PCS Axis Best Practices is a series of topics demonstrating best practices for setting up the PCS Axis® 
database and related services on a network server running Microsoft® SQL Server® 2008 R2. Topics 
include those in the following list:

 Importing Large Amounts of Data in PCS Axis

 Running PCS Axis Job Service (page 2)

 Managing the PCS Axis Database (page 4)

 Running SQL Server (MSSQLServer) Service (page 7)

Importing Large Amounts of Data in PCS Axis

Index fragmentation may occur in the PCS Axis database after importing large amounts of data using 
Bridge Import, Bullhorn Bridge, or Field Computer. Index fragmentation can result in slow system 
performance. The list below identifies best practice methods that can prevent index fragmentation: 

 Enable the option Reindex after import in the Bridge definition of a Bridge Import or Bullhorn 
Bridge. See PCS Axis Help for more information. 

 Create a scheduled database maintenance job on the central database server using the Reindex 
Stored Procedure provided with the PCS Axis installation file. See Creating a Database 
Maintenance Job on the Server (page 17) for more information. 

NOTE: SQL server maintenance jobs can only be created when running a full version of SQL server. 
SQL Server Express does not support this feature. 

Running PCS Axis Job Service

Run the PCS Axis Job Service under a domain account or a SQL Server account with access to the server 
and PCS Axis database. To set up PCS Axis Job Service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 1, page 3). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

PCS Axis Best Practices
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Figure 1.  Computer Management Console

3 Right-click PCS Axis Job Service 1.9 and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 2, page 4). 

4 Click the Log On tab and select the option This account. 

5 Set up PCS Axis Job Service with a user account to log on as a service using a domain account or 
a SQL Server account with access to the server and PCS Axis database. Type the user name and 
password in the appropriate fields (This account, Password, Confirm Password). You can also 
view a list of appropriate user account by clicking Browse > Advanced > Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
database server and PCS Axis database. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 
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Figure 2.  PCS Axis Job Service 1.9 Properties

Managing the PCS Axis Database

Information in this section covers best practices for managing the PCS Axis database using Microsoft® SQL 
Server® Management Studio (SSMS). Topics include those in the following list:

 Setting the Database Owner

 Recommended Autogrowth Setting (page 5)

Setting the Database Owner

To prevent errors from occurring when migrating or restoring the PCS Axis database, or when establishing 
a connection, set the “Owner” of the database using the “sa” account. To set the database “Owner” follow 
these steps: 

1 Start SQL Server Management Studio (SSMS). Click Start > Microsoft SQL Server 2008 R2 > SQL 
Server Management Studio. 

2 Double-click the Databases folder in Object Explorer to open the folder. 

3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the 
Database Properties dialog box (Figure 3, page 5). 

4 Select Files in the Select a page navigation panel. 
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5 Type sa in the Owner field. Then click OK to save changes and close the dialog box. 

Figure 3.  Database Owner

Recommended Autogrowth Setting

Information in this section applies to the PCS Axis database and log file. If you are running PCS Axis in a 
client/server network with synchronization, the information also applies to the publication and subscription 
databases. 

Autogrowth indicates how much additional space is allocated when the PCS Axis database and log file 
require more space. Setting Autogrowth properties allow the PCS Axis database and log file to resize 
automatically based on a predetermined percentage. Because the database resizing process is a significant 
drain on computer resources, it is recommended that you set properties in a manner that does not allow 
the database to constantly resize itself. 

NOTE: When using PCS Axis with synchronization, set Autogrowth properties after you create the 
publication and subscription databases. 

To set Autogrowth properties for the database (_dat) and log (_log) files, follow these steps:

1 Start SSMS. Click Start > Microsoft SQL Server 2008 R2 > SQL Server Management Studio.

2 Double-click Databases in Object Explorer. 
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3 Right-click the PCS Axis database and select Properties in the shortcut menu to open the Database 
Properties dialog box.

4 Click Files in the Select a page navigation panel (Figure 4). 

Figure 4.  Files - Database Properties

5 Complete the following steps to set Autogrowth properties for the database (_dat) and log (_log) 
files: 

a Click the … ellipsis button in the Autogrowth column of the database _dat file to open the 
Change Autogrowth dialog box (Figure 5, page 7). 

b Click the Enable Autogrowth check box to place a check mark inside the check box. 

c For the File Growth property setting, select the option In Percent and then type 10 in the 
adjacent field. This property setting automatically allocates 10% additional space when the 
database requires more space. 

d Click OK to close the Change Autogrowth dialog box.
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e Repeat step 5 (page 6) for the database _log file. 

f Click OK to close the Database Properties dialog box. Then click File > Exit to exit SSMS. 

Figure 5.  Change Autogrowth

Running SQL Server (MSSQLServer) Service

Run the Windows SQL Server (MSSQLSERVER) service under a domain account with access to the PCS 
Axis database. To set up the service, follow these steps: 

1 Click the Windows Start button  and navigate to Computer. Right-click Computer and select 
Manage in the shortcut menu to open the Computer Management console (Figure 6). 

2 Double-click Services and Applications in the left pane of the console. Then click Services to 
display a list of services in the middle pane. 

Figure 6.  Computer Management Console
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3 Right-click SQL Server (MSSQLSERVER) and select Properties in the shortcut menu to open the 
Properties dialog box (Figure 7). 

Figure 7.  SQL Server (MSSQLSERVER) Properties

4 Click the Log On tab and select the option This account. 

5 Set up SQL Server (MSSQLSERVER) with a user account to log on as a service using a domain 
account with access to the PCS Axis database. Type the user name and password in the appropriate 
fields (This account, Password, Confirm Password). You can also view a list of appropriate user 
account by clicking Browse > Advanced > Find Now. 

6 Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

7 Click File > Exit to close the Computer Management console. 
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The procedure in this section explains how to upgrade the PCS Axis database, application, and job service 
agent in a client/server installation. Upgrading the database on the server is accomplished using PCS Axis 
Connection Manager during the upgrade of a client computer. 

Topics in this section include those in the following list: 

 PCS Axis v1.9 Download Package

 Upgrading to PCS Axis v1.9

PCS Axis v1.9 Download Package

Upgrading PCS Axis to v1.9 requires the download package provided by PCS Technical Services. 
Information in an email from PCS Technical Services identifies how to obtain and download a copy of the 
download package to your computer. If you need a copy of the download package, contact PCS Technical 
Services using the contact information on page 28. 

The PCS Axis v1.9 download package includes the following files: 

 PCS Axis v1.9 Installation File: Use this installation file (labeled PCSAxis_1.9.xx.exe) to install PCS 
Axis 1.9 on a 32- or 64-bit computer system. (The letters “xx” are used only as a placeholder to 
represent the actual numbers used in the name of the installation file.) 

 Fill Factor Reset Script: This optional utility script (labeled Defrag Fill Factor Reset Post 
Deployment.SQL) is intended for your company’s Database Administrator (DBA). During the 
upgrade of the PCS Axis database, the “fill factor limit” is set and the Reindex Stored Procedure 
(labeled dbo.DefragmentIndexes) installs in the database. If needed, the DBA can use the optional 
utility script to reset the “fill factor limit” after the database upgrade. 

Upgrading to PCS Axis v1.9

The procedure in this section explains how to upgrade a client computer and the database on the database 
server to PCS Axis v1.9.

Complete the following steps: 

1 Complete the following steps on the database server:

a Run Microsoft® SQL Server Management Studio (SSMS) and establish a connection to the PCS 
Axis database. 

b Use SSMS to make a backup of the PCS Axis database. Exit SSMS when you finish. 

Upgrading a Client/Server Installation of PCS Axis
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2 If you are upgrading PCS Axis v1.4 or earlier, uninstall PCS Axis on the client computer. Click the 
Windows  Start button, then click All Programs > PCS Axis 1.4 > Uninstall PCS 1.4. 

NOTE: The upgrade process automatically uninstalls PCS Axis when upgrading a v1.5 or higher 
installation; manually uninstalling v1.5 or higher is no longer required. Upgrading a version 
previous to v1.5 does however require uninstalling the older version of PCS Axis.

3 Open the folder containing the PCS Axis 1.9 download package. 

4 Double-click the PCS Axis installation file labeled PCSAxis_1.9.xx.exe to open the PCS Axis dialog 
box (Figure 8). The letters “xx” are used only as a placeholder to represent the actual numbers used 
in the name of the installation file. 

Figure 8.  PCS Axis Installation

5 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 9). 

NOTE: After clicking Install the PCS Axis installer verifies if Microsoft .NET Framework is installed 
on the computer. If .NET Framework is not installed, the PCS Axis installer automatically installs .NET 
Framework and then continues with the PCS Axis installation. 

6 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

 

Figure 9.  Setup Wizard
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7 Click Next to display Custom Setup (Figure 10). 

8 By default the  PCS Axis application is selected for installation. The  PCS Axis Job Service 
should not be selected for installation. Verify selections in Custom Setup match those in the next 
figure (Figure 10). 

9 Click Next and then click Install to upgrade the PCS Axis application on the client computer. 

Figure 10.  Custom Setup

10 When the installation completes and after a short delay, PCS Axis Connection Manager opens. 
Click  Close to exit PCS Axis Connection Manager. 

11 Complete the following steps to verify database/server connections and then upgrade the PCS Axis 
database to v1.9: 

a Start PCS Axis Connection Manager. Click the Windows  Start button, then click All 
Programs > PCS Axis 1.9 >  PCS Axis Connection Manager 1.9 (Figure 11, page 12). 

NOTE: Server and Database connection settings automatically carry forward when upgrading 
PCS Axis from a previous version of the software.
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b Click  Test to verify a connection to the PCS Axis database. When the message Connection 
successful displays, click  OK to close the message. 

Figure 11.  PCS Axis Connection Manager

c If the PCS Axis database has previously been upgraded to v1.9, click  Save and then click 
 Close to exit PCS Axis Connection Manager. Continue the upgrade with step 12 (page 

13).

d Click  Create / Upgrade to begin the database upgrade. 

The Create Or Update Database window opens when the upgrade process begins (Figure 12, 
page 13). This window provides status information throughout the process. When the following 
message displays in the window, the database upgrade is complete:

Update completed. 

e Click  Close to close the Create Or Update Database window. 

f Click  Close to exit PCS Axis Connection Manager and then click Finish in Setup Wizard 
to close the PCS Axis installation file. 
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Figure 12.  Create Or Update Database

12 To verify the upgrade installation completed successfully, use the following steps to verify the 
PCS Axis application and database version is 1.9:

a Start PCS Axis on the client computer. Click the Windows  Start button, then click All 
Programs >  PCS Axis 1.9. 

b Click Help > About PCS Axis to open the About window. Verify Version 1.9 displays as shown 
in the following figure (Figure 13). 

NOTE: Clicking Copy To Clipboard in the About window copies the following information to 
the Windows clipboard: database connection; application version; and build information (date 
and time). After copying information to the clipboard, you can then paste it in an email or other 
type of document, such as Microsoft® Word. Use this feature when contacting PCS Technical 
Services for support with PCS Axis. 

Figure 13.  About PCS Axis
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13 Repeat steps 2 through 12 (pages 10-13) to upgrade all other client computers to PCS Axis v1.9. 

14 After upgrading all client computers to v1.9, complete the following steps to upgrade PCS Axis Job 
Service on the network server: 

a Open the folder containing the PCS Axis 1.9 download package.

b Double-click the PCS Axis installation file labeled PCSAxis_1.9.xx.exe to open the PCS Axis 
dialog box (Figure 8, page 10). The letters “xx” are used only as a placeholder to represent the 
actual numbers used in the name of the installation file. 

c Follow on-screen prompts in Setup Wizard. When prompted to install PCS Axis Job Service, 
click the down arrow in  PCS Axis Job Service 1.9 and select the option Entire feature will 
be installed on local hard drive. 

d When the installation completes, click  Close to exit PCS Axis Connection Manager and 
then click Finish in Setup Wizard to close the PCS Axis installation file. 

15 If the PCS Axis Job Service and PCS Axis database are installed on different network servers, set up 
a user account to log on as a service in the following manner. 

IMPORTANT: The user account must be a member of the local domain user group labeled 
Axis_Users. This user group was previously created by your IT Administrator when installing PCS 
Axis for the first time. For more information, see the section entitled Adding the Local Domain 
User Group in the AI document entitled PCS Axis v1.9 Client/Server New Installation with 
Replication. 

a Click the Windows  Start button and navigate to Computer. Right-click Computer and 
select Manage in the shortcut menu to open the Computer Management console (Figure 14, 
page 15). 

b Double-click Services and Applications in the left pane of the console. Then click Services 
to display a list of services in the middle pane. 
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Figure 14.  Computer Management Console

c Right-click PCS Axis Job Service 1.9 in the middle pane (Figure 14) and select Properties in 
the shortcut menu to open the Properties dialog box (Figure 15). 

d Click the Log On tab in the Properties dialog box and select the option This account. To set 
up a user account to log on as a service, type the user name and password in the appropriate 
fields. You can also view a list of appropriate user accounts by clicking Browse > Advanced > 
Find Now. 

NOTE: The user account must be a member of the Axis_Users group and have access to the 
central database server and PCS Axis database. 

e Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 

Figure 15.  PCS Axis Job Service 1.9 Properties
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16 Complete the following steps in the Computer Management console to start PCS Axis Job 
Service: 

a Select PCS Axis Job Service 1.9 and then click Start (Figure 16). 

b Click File > Exit to close the Computer Management console. 

c In PCS Axis, click Tools > Job Service Viewer. Verify the message Running displays in the 
Status field.

Figure 16.  Computer Management Console

17 Notify the Database Administrator (DBA) the PCS Axis database has been upgraded to v1.9. The 
DBA can now schedule a database maintenance job on the server for the PCS Axis database. For 
more details see the next section entitled Creating a Database Maintenance Job on the Server 
(page 17). 

18 The PCS Axis v1.9 upgrade is now complete. If you use PCS Axis replication to synchronize a 
subscription database (remote client), continue with the section Upgrading a PCS Axis 
Subscription for a Remote Client (page 18). 
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Information in this section is intended for the Database Administrator (DBA). The information applies to a 
client/server installation of PCS Axis. 

Included in the v1.9 database upgrade is a new Reindex Stored Procedure labeled 
dbo.DefragmentIndexes. The purpose of the stored procedure is to prevent index fragmentation from 
occurring in the PCS Axis database, which in turn results in slow system performance. Index fragmentation 
may occur after importing large amounts of data in PCS Axis using Bridge Import, Bullhorn Bridge, or 
Field Computer. 

After the database has been upgraded to v1.9, create a scheduled database maintenance job on the 
central database server using the Reindex Stored Procedure. Schedule the database maintenance job to 
run daily or once a week during an off-peak time. Scheduling the database maintenance job at regular 
intervals will ensure optimum system performance by reorganizing and defragmenting the indexes in the 
PCS Axis database. For more information about database maintenance, visit the Microsoft® website at 
http://technet.microsoft.com/en-us/library/ms187658(v=sql.105).aspx. 

NOTE: A process included in the Reindex Stored Procedure sets the “fill factor limit” of the PCS Axis 
database. If you want to reset the “fill factor limit”, use Microsoft SQL Server® Management Studio (SSMS) 
to run the optional utility script provided in the PCS Axis v1.9 download package. The optional utility script 
is labeled Defrag Fill Factor Reset Post Deployment.SQL.

After the PCS Axis database has been upgraded to v1.9, complete the following steps on the central 
database server: 

1 Start SQL Server Management Studio (SSMS). Click Start > All Programs > Microsoft SQL Server 
2008 R2 > SQL Server Management Studio. 

2 Use SSMS to create a scheduled database maintenance job for the PCS Axis database using the 
Reindex Stored Procedure labeled dbo.DefragmentIndexes. Set the job to run daily or once a 
week during an off-peak time. 

IMPORTANT:  AI recommends running the stored procedure daily or once a week during non-peak 
hours. 

For a best practice guide in creating database maintenance jobs, visit the Microsoft website at
http://technet.microsoft.com/en-us/library/ms187658(v=sql.105).aspx.

3 Exit SSMS. 

Creating a Database Maintenance Job on the Server
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Information in this section explains how to upgrade a subscription database on a remote client computer. 
If you are using PCS Axis in a client/server network with replication, the PCS Axis database on the central 
database server must first be upgraded before completing the instructions in this section. If needed, see 
Upgrading a Client/Server Installation of PCS Axis (page 9) for more information. 

Upgrading a subscription includes the following tasks: 

 Synchronize the subscription database with the PCS Axis database on the central database server. 
The synchronization process upgrades the subscription database to v1.9. 

 Upgrade the PCS Axis application using the installation file provided in a download package from 
PCS Technical Services. For more information about the download package, see PCS Axis v1.9 
Download Package (page 9). 

Complete the following steps: 

1 Synchronize the subscription database with the publication database as follows:

a Start PCS Axis. Click the Windows  Start button, then click All Programs >   PCS Axis 1.9. 

b Click Tools in the main menu and then select Synchronize Now. 

NOTE: The synchronization process upgrades the subscription database. When the process 
completes, a message displays stating the database is at a higher version than the application 
and then PCS Axis shuts down. 

2 If you are upgrading PCS Axis v1.4 or earlier, uninstall PCS Axis. Click the Windows  Start 
button, then click All Programs >  PCS Axis 1.4 > Uninstall PCS 1.4. 

NOTE: The upgrade process automatically uninstalls PCS Axis when upgrading a v1.5 or higher 
installation; manually uninstalling v1.5 or higher is no longer required. Upgrading a version 
previous to v1.5 does however require uninstalling the older version of PCS Axis.

Upgrading a PCS Axis Subscription for a Remote Client
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3 Complete the following steps to install the PCS Axis v1.9 application: 

a Open the folder containing the PCS Axis 1.9 download package. 

b Double-click the installation file labeled PCSAxis_1.9.xx.exe to open the PCS Axis dialog box 
(Figure 17). The letters “xx” are used only as a placeholder to represent the actual numbers 
used in the name of the installation file. 

Figure 17.  PCS Axis Installation

c Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 18). 

NOTE: After clicking Install the PCS Axis installer verifies if Microsoft .NET Framework is 
installed on the computer. If .NET Framework is not installed, the PCS Axis installer 
automatically installs it and then continues with the PCS Axis installation. 

 

Figure 18.  Setup Wizard
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d Click Next to display Custom Setup (Figure 19). 

e By default the  PCS Axis application is selected for installation. The  PCS Axis Job 
Service should not be selected for installation. Verify selections in Custom Setup match those 
in the next figure (Figure 19). 

f Click Next and then click Install to upgrade the PCS Axis application. 

Figure 19.  Custom Setup

4 When the installation completes and after a short delay, PCS Axis Connection Manager opens. 
Click  Close to exit PCS Axis Connection Manager. 

5 Complete the following steps to verify a connection to the subscription database: 

a Start PCS Axis Connection Manager. Click the Windows  Start button, then click 
PCS Axis 1.9 >  PCS Axis Connection Manager 1.9 (Figure 20, page 21). 

b Click  Test in the Subscription group box to verify a connection to the subscription 
database. 

c When the message Connection successful displays, click  OK to close the message. Then 
click  Close to exit Connection Manager. 

6 Repeat steps 1 through 5 (pages 18-20) to upgrade all other subscriptions to PCS Axis v1.9. 

The subscription upgrade installation is now complete. 
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Figure 20.  Connection Manager
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The procedure in this section explains how to upgrade a local installation of PCS Axis for a single-user in a 
non-client/server network. The process upgrades the PCS Axis database, application, and job service agent 
to v1.9. 

Upgrade the PCS Axis application and database using the installation file provided in a download package 
from PCS Technical Services. For more information about the download package, see PCS Axis v1.9 
Download Package (page 9). 

Complete the following steps: 

1 Make a backup of the PCS Axis database using the following steps: 

a Run Microsoft SQL Server Management Studio (SSMS) and establish a connection to the PCS 
Axis database. 

b Use SSMS to make a backup of the PCS Axis database. Exit SSMS when you finish. 

2 If you are upgrading PCS Axis v1.4 or earlier, uninstall PCS Axis. Click the Windows  Start 
button, then click All Programs >  PCS Axis 1.4 > Uninstall PCS 1.4. 

NOTE: The upgrade process automatically uninstalls PCS Axis when upgrading a v1.5 or higher 
installation; manually uninstalling v1.5 or higher is no longer required. Upgrading a version 
previous to v1.5 does however require uninstalling the older version of PCS Axis.

3 Open the folder containing the PCS Axis 1.9 download package.

4 Double-click the PCS Axis installation file labeled PCSAxis_1.9.xx.exe to open the PCS Axis dialog 
box (Figure 21). The letters “xx” are used only as a placeholder to represent the actual numbers 
used in the name of the installation file. 

Figure 21.  PCS Axis Installation

Upgrading a Single-User Local Installation in a Non-Client/Server Network
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5 Click Install in the PCS Axis dialog box to open Setup Wizard (Figure 22). 

NOTE: After clicking Install the PCS Axis installer verifies if Microsoft .NET Framework is installed 
on the computer. If .NET Framework is not installed, the PCS Axis installer automatically installs it 
and then continues with the PCS Axis installation. 

6 Click Next to read the End-User License Agreement. To accept the license agreement, click the 
check box I accept the terms in the License Agreement to place a check mark inside the check box. 

 

Figure 22.  Setup Wizard

7 Click Next to display Custom Setup (Figure 23). 

8 By default the  PCS Axis application is selected for installation as shown in the next figure 
(Figure 23). No changes are required to the default setting. 

Figure 23.  Custom Setup
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9 Click the down arrow in  PCS Axis Job Service and select the option Entire feature will be 
installed on local hard drive to upgrade the job service. 

10 Click Next and then click Install to begin the installation. 

11 When the installation completes and after a short delay, PCS Axis Connection Manager opens. 
Click  Close to exit PCS Axis Connection Manager. 

12 Complete the following steps to verify database/server connections and then upgrade the PCS Axis 
database to v1.9.

a Start PCS Axis Connection Manager. Click the Windows  Start button, then click All 
Programs > PCS Axis 1.9 >  PCS Axis Connection Manager 1.9 (Figure 24). 

NOTE: Server and Database connection settings automatically carry forward when upgrading 
PCS Axis from a previous version of the software.

b Click  Test to verify a connection to the PCS Axis database. When the message Connection 
successful displays, click  OK to close the message. Then click  Save.

Figure 24.  PCS Axis Connection Manager

c Click  Create / Upgrade to begin the database upgrade. 

The Create Or Update Database window opens when the upgrade process begins (Figure 25, 
page 25). This window provides status information throughout the process. When the message 
Update completed displays in the window, the database upgrade is complete. 

d Click  Close to close the Create Or Update Database window. 

e Click  Close to exit PCS Axis Connection Manager. Then click Finish in Setup Wizard to 
close the PCS Axis installation file. 
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Figure 25.  Create Or Update Database

13 To verify the upgrade installation completed successfully, use the following steps to verify the 
PCS Axis application and database version is 1.9: 

a Start PCS Axis on the client computer. Click the Windows  Start button, then click All 
Programs >  PCS Axis 1.9. 

b Click Help > About PCS Axis to open the About window. Verify Version 1.9 displays as shown 
in the following figure (Figure 26). If the version number is different, contact PCS Technical 
Services for assistance using the contact information on page 28. 

NOTE: Clicking Copy To Clipboard in the About window copies the following information to 
the Windows clipboard: database connection; application version; and build information (date 
and time). After copying information to the clipboard, you can then paste it in an email or other 
type of document, such as Microsoft® Word. Use this feature when contacting PCS Technical 
Services for support with PCS Axis. 

Figure 26.  About PCS Axis
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14 Complete the following steps to start PCS Axis Job Service: 

a Click the Windows  Start button and navigate to Computer. Right-click Computer and 
select Manage in the shortcut menu to open the Computer Management console (Figure 27). 

b Double-click Services and Applications in the left pane of the console. Then click Services 
to display a list of services in the middle pane. 

Figure 27.  Computer Management Console

c Right-click PCS Axis Job Service 1.9 (Figure 27) and select Properties in the shortcut menu 
to open the Properties dialog box (Figure 28, page 27). 

d Click the Log On tab and select the option Local System account. Then click the check box 
Allow service to interact with desktop. 

e Click Apply and then OK to close the Properties dialog box and return to the Computer 
Management console. 
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Figure 28.  PCS Axis Job Service 1.9 Properties

f Select PCS Axis Job Service 1.9 and then click Start (Figure 29). 

g Click File > Exit to close the Computer Management console. 

h In PCS Axis, click Tools > Job Service Viewer. Verify the message Running displays in the 
Status field.

The PCS Axis v1.9 upgrade is now complete. 

Figure 29.  Computer Management Console
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If you have a suggestion, question, feature request, or a bug to report-your feedback would be 
appreciated. Also if you have a training need for your organization or would like to know more about 
upcoming PCS Axis training classes, use any of the following contact information to reach PCS Technical 
Services:

Support E-mail: pcstechservices@aiworldwide.com

Support Telephone: 1-800-229-3404 (select 1, then press 2)

American Innovations: http://www.aiworldwide.com

Product Support and Training
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